summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-02-14 08:37:08 +0100
committerxengineering <me@xengineering.eu>2025-02-14 09:03:18 +0100
commit298cb131149f583ab986ee69901765c3dbcce674 (patch)
tree83e93b0429b8d6d5919fe049fc9262db9735ed74 /CMakeLists.txt
parentee9106047c2128e8be07e754157c71c92a77a442 (diff)
downloadiot-contact-298cb131149f583ab986ee69901765c3dbcce674.tar
iot-contact-298cb131149f583ab986ee69901765c3dbcce674.tar.zst
iot-contact-298cb131149f583ab986ee69901765c3dbcce674.zip
Switch to a global CMake build
This allows to easily build everything from the repository root. For now this only covers firmware but later electrical PCB and mechanical case files can be added.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..7d5602c
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,5 @@
+cmake_minimum_required(VERSION 3.10)
+
+project(iot-contact LANGUAGES NONE)
+
+add_subdirectory(fw)