summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-22 21:21:44 +0100
committerxengineering <me@xengineering.eu>2025-03-22 21:21:44 +0100
commit0c771fb52f864c867d2fcff795e4d3ebd8de1c7c (patch)
treeac6bf864270be669b73997e5a3e14edf6708de12 /fw/CMakeLists.txt
parent9f2ce4cc9ba9ad45a7e88247f8c1fb0953717b0e (diff)
downloadiot-contact-0c771fb52f864c867d2fcff795e4d3ebd8de1c7c.tar
iot-contact-0c771fb52f864c867d2fcff795e4d3ebd8de1c7c.tar.zst
iot-contact-0c771fb52f864c867d2fcff795e4d3ebd8de1c7c.zip
fw: firmware: Add app build version output
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 1b978b7..0541836 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -43,6 +43,7 @@ target_sources(app
"${CMAKE_CURRENT_SOURCE_DIR}/src/http.c"
"${CMAKE_CURRENT_SOURCE_DIR}/src/ws.c"
"${CMAKE_CURRENT_SOURCE_DIR}/src/heart.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/firmware.c"
)
zephyr_linker_sources(SECTIONS sections-rom.ld)