summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-21 22:47:57 +0100
committerxengineering <me@xengineering.eu>2025-03-21 22:47:57 +0100
commit61238e93e2c5b3c672d3a55f6273bfd3615f05d7 (patch)
tree149fc86de88c5665013e999f7f685e062ad9ae0c /fw/CMakeLists.txt
parent56ca2f692a95c3ecb97eff191d47d8c5e92e25c1 (diff)
downloadiot-contact-61238e93e2c5b3c672d3a55f6273bfd3615f05d7.tar
iot-contact-61238e93e2c5b3c672d3a55f6273bfd3615f05d7.tar.zst
iot-contact-61238e93e2c5b3c672d3a55f6273bfd3615f05d7.zip
fw: Add mcuboot submodule
This provides the source code for the used bootloader.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index d1e1d90..8d9591f 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -9,6 +9,7 @@ set(ZEPHYR_MODULES
"${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/modules/hal/cmsis"
"${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/modules/hal/stm32"
"${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/modules/crypto/mbedtls"
+ "${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/bootloader/mcuboot"
)
find_package(Zephyr
REQUIRED