summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-21 22:07:26 +0100
committerxengineering <me@xengineering.eu>2025-03-21 22:07:26 +0100
commitfcbd6ac3415d4a122d21b2e379ccf170620f45da (patch)
tree9d13560f540ce89a737192f731bdcfeabb76d899 /fw/CMakeLists.txt
parent5f457c4786b270f0918294b09f32c484f165e2ef (diff)
downloadiot-contact-fcbd6ac3415d4a122d21b2e379ccf170620f45da.tar
iot-contact-fcbd6ac3415d4a122d21b2e379ccf170620f45da.tar.zst
iot-contact-fcbd6ac3415d4a122d21b2e379ccf170620f45da.zip
fw: syslog: Add static syslog logging
Network-based logging via the syslog protocol allows to log from many IoT devices to a central log server. This makes reading logs way easier. Choosing UDP removes the need for logic keeping a state. Maybe dropped packages are acceptable for the use case but should be rare anyway.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 6ba8cec..522a4dd 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -20,4 +20,5 @@ project(iot-contact-fw)
target_sources(app
PRIVATE
"${CMAKE_CURRENT_SOURCE_DIR}/src/main.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/syslog.c"
)