summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-02-14 08:37:08 +0100
committerxengineering <me@xengineering.eu>2025-02-14 09:03:18 +0100
commit298cb131149f583ab986ee69901765c3dbcce674 (patch)
tree83e93b0429b8d6d5919fe049fc9262db9735ed74 /fw/CMakeLists.txt
parentee9106047c2128e8be07e754157c71c92a77a442 (diff)
downloadiot-contact-298cb131149f583ab986ee69901765c3dbcce674.tar
iot-contact-298cb131149f583ab986ee69901765c3dbcce674.tar.zst
iot-contact-298cb131149f583ab986ee69901765c3dbcce674.zip
Switch to a global CMake build
This allows to easily build everything from the repository root. For now this only covers firmware but later electrical PCB and mechanical case files can be added.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 5cd52ce..000039e 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -15,9 +15,9 @@ find_package(Zephyr
"${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/zephyr"
)
-project(iot-contact)
+project(iot-contact-fw)
target_sources(app
PRIVATE
- src/main.c
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/main.c"
)