summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-02-11 07:14:29 +0100
committerxengineering <me@xengineering.eu>2025-02-11 11:59:32 +0100
commit57182e7bfad6c635140184db97477559393e2047 (patch)
treec732eae6b809d4eaa6581ff2d55b04e3233c21db /fw/CMakeLists.txt
parent304e1e443dc1283efbd1fe8b4a72c13f6cfc2fe4 (diff)
downloadiot-contact-57182e7bfad6c635140184db97477559393e2047.tar
iot-contact-57182e7bfad6c635140184db97477559393e2047.tar.zst
iot-contact-57182e7bfad6c635140184db97477559393e2047.zip
fw: Switch to MPL 2.0
The Mozilla Public License seems to be suitable for this firmware project. See the original license text for details. This commit also adds a `.txt` suffix to the LICENSE file to make the file type more visible to humans and tools.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index b0093d0..45ce176 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -1,3 +1,7 @@
+# This Source Code Form is subject to the terms of the Mozilla Public License,
+# v. 2.0. If a copy of the MPL was not distributed with this file, You can
+# obtain one at https://mozilla.org/MPL/2.0/.
+
cmake_minimum_required(VERSION 3.20.0)
set(BOARD "nucleo_f767zi")