summaryrefslogtreecommitdiff
path: root/fw/btl/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-06 17:27:49 +0200
committerxengineering <me@xengineering.eu>2025-04-06 17:27:49 +0200
commite78341079228b135bee65deb8e0d4e2b4385cf94 (patch)
tree2b6287e9fe31efc0335358d5cd3f95e3652117e9 /fw/btl/meson.build
parent04e504c94db921d45b63c7ea75389d692de6738e (diff)
downloadiot-contact-e78341079228b135bee65deb8e0d4e2b4385cf94.tar
iot-contact-e78341079228b135bee65deb8e0d4e2b4385cf94.tar.zst
iot-contact-e78341079228b135bee65deb8e0d4e2b4385cf94.zip
tools: Add directory and move scripts here
This allows to re-use these scripts. Since they are currently used to build Zephyr builds and three are intended (application, bootloader and application as native_sim build) this makes sense.
Diffstat (limited to 'fw/btl/meson.build')
-rw-r--r--fw/btl/meson.build5
1 files changed, 3 insertions, 2 deletions
diff --git a/fw/btl/meson.build b/fw/btl/meson.build
index 37c8c25..ed40cd3 100644
--- a/fw/btl/meson.build
+++ b/fw/btl/meson.build
@@ -1,6 +1,7 @@
external_project = import('unstable-external_project')
-bootloader_project = external_project.add_project('configure.py',
+bootloader_project = external_project.add_project(
+ configure_zephyr,
configure_options: [
bootloader_firmware,
meson.current_build_dir() / 'build',
@@ -16,7 +17,7 @@ bootloader_project = external_project.add_project('configure.py',
bootloader = custom_target('bootloader',
output: ['bootloader.bin'],
command: [
- meson.current_source_dir() / 'build.py',
+ build_zephyr,
meson.current_build_dir() / 'build',
],
build_by_default: true,