summaryrefslogtreecommitdiff
path: root/fw/rtos/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-06 19:16:48 +0200
committerxengineering <me@xengineering.eu>2025-04-06 19:16:48 +0200
commit8cc751f284b15ff3dbc5b1ba27e3733671cb964c (patch)
tree8b29de6c0e04c543baa8fa2eea6c171446a690d5 /fw/rtos/CMakeLists.txt
parent71f6c1991f0451df4c5c92fd8cd8302146fcbf6f (diff)
downloadiot-contact-8cc751f284b15ff3dbc5b1ba27e3733671cb964c.tar
iot-contact-8cc751f284b15ff3dbc5b1ba27e3733671cb964c.tar.zst
iot-contact-8cc751f284b15ff3dbc5b1ba27e3733671cb964c.zip
Remove top-level CMake build system
Meson now handles this. CMake is only used as Meson external project to build Zephyr firmwares.
Diffstat (limited to 'fw/rtos/CMakeLists.txt')
-rw-r--r--fw/rtos/CMakeLists.txt16
1 files changed, 0 insertions, 16 deletions
diff --git a/fw/rtos/CMakeLists.txt b/fw/rtos/CMakeLists.txt
deleted file mode 100644
index d9f116c..0000000
--- a/fw/rtos/CMakeLists.txt
+++ /dev/null
@@ -1,16 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public License,
-# v. 2.0. If a copy of the MPL was not distributed with this file, You can
-# obtain one at https://mozilla.org/MPL/2.0/.
-
-set(ZEPHYR_MODULES
- "${CMAKE_CURRENT_SOURCE_DIR}/modules/cmsis"
- "${CMAKE_CURRENT_SOURCE_DIR}/modules/hal_stm32"
- "${CMAKE_CURRENT_SOURCE_DIR}/modules/mbedtls"
- "${CMAKE_CURRENT_SOURCE_DIR}/modules/mcuboot"
- PARENT_SCOPE
-)
-
-set(ZEPHYR_BASE
- "${CMAKE_CURRENT_SOURCE_DIR}/zephyr"
- PARENT_SCOPE
-)