summaryrefslogtreecommitdiff
path: root/fw/sim/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-07 19:52:37 +0200
committerxengineering <me@xengineering.eu>2025-05-07 19:58:14 +0200
commit46b537fb86e029978d9a1f8aa5d07ec2949ea7a1 (patch)
tree71ef55ce4a9862d57bdc401c739363fb9f99894b /fw/sim/meson.build
parenta5aafcbd0398ae3893a83827cf66d4352eaee8f0 (diff)
downloadiot-contact-46b537fb86e029978d9a1f8aa5d07ec2949ea7a1.tar
iot-contact-46b537fb86e029978d9a1f8aa5d07ec2949ea7a1.tar.zst
iot-contact-46b537fb86e029978d9a1f8aa5d07ec2949ea7a1.zip
WIP: Remove installation stepimprove-buildsystem
TODO: Check if the bootloader install target is still usable. Using the installation step to copy selected artifacts into on folder was anyway a hack. This commit shows that the complexity can be reduced by adding copy targets. The `build/artifacts` folder contains the selected artifacts, they are always up to date, the user does not have to call the install step separately and the target definitions do not require install-related keyword arguments.
Diffstat (limited to 'fw/sim/meson.build')
-rw-r--r--fw/sim/meson.build3
1 files changed, 0 insertions, 3 deletions
diff --git a/fw/sim/meson.build b/fw/sim/meson.build
index 7667f9b..5edcad9 100644
--- a/fw/sim/meson.build
+++ b/fw/sim/meson.build
@@ -13,7 +13,6 @@ external_project.add_project(
)
simulation = custom_target(
- 'simulation',
output: ['simulation-linux-amd64.exe'],
command: [
build_zephyr,
@@ -22,6 +21,4 @@ simulation = custom_target(
'--target-name', 'simulation-linux-amd64.exe',
],
build_by_default: true,
- install: true,
- install_dir: '/',
)