summaryrefslogtreecommitdiff
path: root/web/content/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-05 10:36:38 +0200
committerxengineering <me@xengineering.eu>2025-04-05 12:26:17 +0200
commit061a67ea6e4a7fb9658fd3efc1c670eae5ff3eb6 (patch)
treecc6bf423db4fcde43fa2496562de88bac5fee161 /web/content/meson.build
parentec8958e5ded76bd148e2cb4efbd22603555b93f5 (diff)
downloadiot-contact-061a67ea6e4a7fb9658fd3efc1c670eae5ff3eb6.tar
iot-contact-061a67ea6e4a7fb9658fd3efc1c670eae5ff3eb6.tar.zst
iot-contact-061a67ea6e4a7fb9658fd3efc1c670eae5ff3eb6.zip
Deploy schematic and BOM to website
These important design files should be deployed with the website.
Diffstat (limited to 'web/content/meson.build')
-rw-r--r--web/content/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/web/content/meson.build b/web/content/meson.build
index 75d3120..5046982 100644
--- a/web/content/meson.build
+++ b/web/content/meson.build
@@ -3,3 +3,27 @@ configure_file(
output: 'simple.css',
copy: true,
)
+
+schematic_web = custom_target('schematic_web',
+ output: ['schematic.pdf'],
+ command: [
+ 'copy.py',
+ schematic_pdf,
+ meson.current_build_dir() / 'schematic.pdf'
+ ],
+ depends: [
+ schematic,
+ ],
+)
+
+bom_web = custom_target('bom_web',
+ output: ['bill-of-materials.csv'],
+ command: [
+ 'copy.py',
+ bom_csv,
+ meson.current_build_dir() / 'bill-of-materials.csv'
+ ],
+ depends: [
+ bom,
+ ],
+)