summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-05 15:28:04 +0200
committerxengineering <me@xengineering.eu>2025-04-05 15:28:04 +0200
commit00189e737517f4470336d819d52327a037509493 (patch)
tree8f7d2f3e616a89b807cf2986ecc6ee6876f99392 /web/meson.build
parent061a67ea6e4a7fb9658fd3efc1c670eae5ff3eb6 (diff)
downloadiot-contact-00189e737517f4470336d819d52327a037509493.tar
iot-contact-00189e737517f4470336d819d52327a037509493.tar.zst
iot-contact-00189e737517f4470336d819d52327a037509493.zip
web: Replace file copying by Meson installation
This makes the build system code way less hacky and more modular.
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build13
1 files changed, 6 insertions, 7 deletions
diff --git a/web/meson.build b/web/meson.build
index 1c64394..1526621 100644
--- a/web/meson.build
+++ b/web/meson.build
@@ -1,12 +1,9 @@
-subdir('content')
-
website = custom_target('website',
- output: ['public'],
+ output: ['index.html'],
command: [
'hugo',
'--source', meson.current_source_dir(),
- '--destination', meson.current_build_dir() / 'public',
- '--contentDir', meson.current_build_dir() / 'content',
+ '--destination', meson.current_build_dir(),
],
depend_files: [
'hugo.toml',
@@ -14,8 +11,10 @@ website = custom_target('website',
'layouts/home.html',
],
depends: [
- schematic_web,
- bom_web,
+ schematic,
+ bom,
],
build_by_default: true,
+ install: true,
+ install_dir: 'website',
)