summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-06 20:02:56 +0200
committerxengineering <me@xengineering.eu>2025-04-06 20:02:56 +0200
commitee1dea051b0a43c02cf56dfc6a812c1a32910bc6 (patch)
tree6f555191efc74f7ada207990a233466e953175b8 /web/meson.build
parentd19fc7e34f783b343e77b757c4f37aaadb5b66ca (diff)
parentda27d61588202d6b460e36d29a8789d206495bd6 (diff)
downloadiot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.tar
iot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.tar.zst
iot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.zip
Merge website and CMake to Meson transition
Building a website to structure and deploy the artifacts was planned and requires a well set-up build system to handle all the file paths targets and dependencies. Since multiple CMake Zephyr builds are required for the application firmware, bootloader firmware and the native_sim application firmware simulation CMake external project was used. Since this generates a build tree with a confusing structure Meson was evaluated. Finally the Meson build system was a good fit as top-level build system and allows external projects as an experimental feature if they can configure a Make-based build system which is given for Zephyr.
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/web/meson.build b/web/meson.build
new file mode 100644
index 0000000..da45440
--- /dev/null
+++ b/web/meson.build
@@ -0,0 +1,22 @@
+website = custom_target('website',
+ output: ['index.html'],
+ command: [
+ 'hugo',
+ '--source', meson.current_source_dir(),
+ '--destination', meson.current_build_dir(),
+ ],
+ depend_files: [
+ 'hugo.toml',
+ 'layouts/baseof.html',
+ 'layouts/home.html',
+ ],
+ depends: [
+ schematic,
+ bom,
+ application,
+ bootloader,
+ ],
+ build_by_default: true,
+ install: true,
+ install_dir: 'website',
+)