summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-03 21:45:55 +0200
committerxengineering <me@xengineering.eu>2025-04-03 21:50:55 +0200
commit34c0c109551c3a67bb89dcfbcd437a5ed812809f (patch)
tree09081730f4a582befff1d8615953455512301310 /web/meson.build
parentdb02eb87ce5e955f1c970ea3ce88745e03f0bb74 (diff)
downloadiot-contact-34c0c109551c3a67bb89dcfbcd437a5ed812809f.tar
iot-contact-34c0c109551c3a67bb89dcfbcd437a5ed812809f.tar.zst
iot-contact-34c0c109551c3a67bb89dcfbcd437a5ed812809f.zip
web: Add simple.css to website
This uses meson to copy the simple.css file to the build dir and references the CSS file in the HTML code.
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build9
1 files changed, 5 insertions, 4 deletions
diff --git a/web/meson.build b/web/meson.build
index 3fcffed..20a4520 100644
--- a/web/meson.build
+++ b/web/meson.build
@@ -1,11 +1,12 @@
+subdir('content')
+
custom_target('website',
output: ['public'],
command: [
'hugo',
- '--source',
- meson.current_source_dir(),
- '--destination',
- meson.current_build_dir() / 'public',
+ '--source', meson.current_source_dir(),
+ '--destination', meson.current_build_dir() / 'public',
+ '--contentDir', meson.current_build_dir() / 'content',
],
depend_files: [
'hugo.toml',