summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-07 21:36:41 +0200
committerxengineering <me@xengineering.eu>2025-04-07 21:36:41 +0200
commit4ee031182475464fe0ecb052882fd50520e6defc (patch)
tree8189ae0fb64ded64163cfd5edc39086cc6795c42 /web/meson.build
parent1b13c51a6ab5fd1df1b7e960d54dc6b6f3a4d591 (diff)
downloadiot-contact-4ee031182475464fe0ecb052882fd50520e6defc.tar
iot-contact-4ee031182475464fe0ecb052882fd50520e6defc.tar.zst
iot-contact-4ee031182475464fe0ecb052882fd50520e6defc.zip
Simplify website structure and drop Hugo
A static site generator is currently not really required. A static index.html is currently sufficient.
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build24
1 files changed, 4 insertions, 20 deletions
diff --git a/web/meson.build b/web/meson.build
index da45440..f8c2024 100644
--- a/web/meson.build
+++ b/web/meson.build
@@ -1,22 +1,6 @@
-website = custom_target('website',
- output: ['index.html'],
- command: [
- 'hugo',
- '--source', meson.current_source_dir(),
- '--destination', meson.current_build_dir(),
- ],
- depend_files: [
- 'hugo.toml',
- 'layouts/baseof.html',
- 'layouts/home.html',
- ],
- depends: [
- schematic,
- bom,
- application,
- bootloader,
- ],
- build_by_default: true,
+website = fs.copyfile(
+ meson.current_source_dir() / 'index.html',
+ 'index.html',
install: true,
- install_dir: 'website',
+ install_dir: '/',
)