summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index d07494b..cffb6a1 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -30,6 +30,9 @@ zephyr_linker_section(NAME http_resource_desc_http_service
KVMA RAM_REGION GROUP RODATA_REGION
SUBALIGN ${CONFIG_LINKER_ITERABLE_SUBALIGN})
-set(gen_dir ${ZEPHYR_BINARY_DIR}/include/generated/)
-set(source_file_index src/html/index.html)
-generate_inc_file_for_target(app ${source_file_index} ${gen_dir}/index.html.gz.inc --gzip)
+generate_inc_file_for_target(
+ app
+ src/index.html
+ ${ZEPHYR_BINARY_DIR}/include/generated/index.html.gz.inc
+ --gzip
+)