summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 32a4571..d07494b 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -22,4 +22,14 @@ target_sources(app
"${CMAKE_CURRENT_SOURCE_DIR}/src/main.c"
"${CMAKE_CURRENT_SOURCE_DIR}/src/syslog.c"
"${CMAKE_CURRENT_SOURCE_DIR}/src/mac.c"
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/http.c"
)
+
+zephyr_linker_sources(SECTIONS sections-rom.ld)
+zephyr_linker_section(NAME http_resource_desc_http_service
+ KVMA RAM_REGION GROUP RODATA_REGION
+ SUBALIGN ${CONFIG_LINKER_ITERABLE_SUBALIGN})
+
+set(gen_dir ${ZEPHYR_BINARY_DIR}/include/generated/)
+set(source_file_index src/html/index.html)
+generate_inc_file_for_target(app ${source_file_index} ${gen_dir}/index.html.gz.inc --gzip)