summaryrefslogtreecommitdiff
path: root/web/content/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'web/content/meson.build')
-rw-r--r--web/content/meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/web/content/meson.build b/web/content/meson.build
index 75d3120..5046982 100644
--- a/web/content/meson.build
+++ b/web/content/meson.build
@@ -3,3 +3,27 @@ configure_file(
output: 'simple.css',
copy: true,
)
+
+schematic_web = custom_target('schematic_web',
+ output: ['schematic.pdf'],
+ command: [
+ 'copy.py',
+ schematic_pdf,
+ meson.current_build_dir() / 'schematic.pdf'
+ ],
+ depends: [
+ schematic,
+ ],
+)
+
+bom_web = custom_target('bom_web',
+ output: ['bill-of-materials.csv'],
+ command: [
+ 'copy.py',
+ bom_csv,
+ meson.current_build_dir() / 'bill-of-materials.csv'
+ ],
+ depends: [
+ bom,
+ ],
+)