summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2022-10-07 19:58:38 +0200
committerxengineering <me@xengineering.eu>2022-10-07 20:40:42 +0200
commit54732fa0ffc24c87aa9dc786a47545c675c28cec (patch)
tree44019c1452b98f327668d8c5e8a83b33693fe74f /meson.build
parent5154cdd51ddb4beed58f0082b5792516343966ed (diff)
downloadlimox-54732fa0ffc24c87aa9dc786a47545c675c28cec.tar
limox-54732fa0ffc24c87aa9dc786a47545c675c28cec.tar.zst
limox-54732fa0ffc24c87aa9dc786a47545c675c28cec.zip
Add empty SDL based gui.h implementation
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9bd034a..4b57931 100644
--- a/meson.build
+++ b/meson.build
@@ -1,4 +1,6 @@
project('LimoX', 'c')
gtkdep = dependency('gtk4')
strophedep = dependency('libstrophe')
+sdldep = dependency('sdl2')
executable('limox', ['main.c', 'gtk.c', 'net.c', 'data.c'], dependencies : [gtkdep, strophedep])
+executable('limox_sdl', ['main.c', 'sdl.c', 'net.c', 'data.c'], dependencies : [sdldep, strophedep])