summaryrefslogtreecommitdiff
path: root/mech/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2024-12-27 13:38:16 +0100
committerxengineering <me@xengineering.eu>2025-01-01 15:31:47 +0100
commit3f76d754866d26333c43d8403c0e694f9df972a4 (patch)
treeed67d7e0a176af9867bcb25bcd3ccf0908d9df01 /mech/CMakeLists.txt
parent63088edf667f49fa3f0eaf2f88074e671c5e0a6b (diff)
downloadsoundbox-3f76d754866d26333c43d8403c0e694f9df972a4.tar
soundbox-3f76d754866d26333c43d8403c0e694f9df972a4.tar.zst
soundbox-3f76d754866d26333c43d8403c0e694f9df972a4.zip
mech: Add CMake-based build systemcmake
Diffstat (limited to 'mech/CMakeLists.txt')
-rw-r--r--mech/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/mech/CMakeLists.txt b/mech/CMakeLists.txt
new file mode 100644
index 0000000..9b045ba
--- /dev/null
+++ b/mech/CMakeLists.txt
@@ -0,0 +1,19 @@
+include(mech.cmake)
+
+set(
+ printer_config
+ "${CMAKE_CURRENT_SOURCE_DIR}/prusa-slicer/anycubic_i3_mega_s.ini"
+)
+
+set(
+ prints
+ "${CMAKE_CURRENT_SOURCE_DIR}/assembly.scad"
+ "${CMAKE_CURRENT_SOURCE_DIR}/production.scad"
+)
+
+foreach(print ${prints})
+ openscad(${print})
+ prusa_slicer(${print} ${printer_config})
+endforeach()
+
+add_subdirectory(pcb_case)