summaryrefslogtreecommitdiff
path: root/archlinux/PKGBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'archlinux/PKGBUILD')
-rw-r--r--archlinux/PKGBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/archlinux/PKGBUILD b/archlinux/PKGBUILD
new file mode 100644
index 0000000..c61ab99
--- /dev/null
+++ b/archlinux/PKGBUILD
@@ -0,0 +1,37 @@
+
+# Maintainer: xengineering <mail2xengineering@protonmail.com>
+pkgname=birdscan
+pkgver=0.0.1
+pkgrel=1
+epoch=
+pkgdesc="A software to take beautiful pictures of birds with a Raspberry Pi Camera"
+arch=("armv7h" "x86_64")
+url="https://xengineering.eu"
+license=("AGPL3")
+groups=()
+depends=("licenses" "python")
+makedepends=("go")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=("etc/birdscan/config.json")
+options=()
+install=
+changelog=
+source=("${pkgname}.tar.gz")
+noextract=()
+md5sums=("SKIP")
+validpgpkeys=()
+
+build() {
+ cd "$pkgname" # -$pkgver"
+ make all
+}
+
+package() {
+ cd "$pkgname" # -$pkgver"
+ make install DESTDIR=$pkgdir
+}
+