summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-23 18:33:19 +0100
committerxengineering <me@xengineering.eu>2025-03-26 21:18:23 +0100
commit1fcf9bd0d1af10c57a67d90496b5406244ca25ba (patch)
tree2b660699ed6903afb586d45322c82fab84848bc3 /fw/CMakeLists.txt
parent1eabe70aae439fbc00325d27749d1464320d8a03 (diff)
downloadiot-contact-1fcf9bd0d1af10c57a67d90496b5406244ca25ba.tar
iot-contact-1fcf9bd0d1af10c57a67d90496b5406244ca25ba.tar.zst
iot-contact-1fcf9bd0d1af10c57a67d90496b5406244ca25ba.zip
fw: rtos: modules: Move mcuboot submodule here
The mcuboot Git submodule used to be located in `fw/btl`. Nevertheless since it is also a Zephyr module it should go to `fw/rtos/modules`. This makes sure all Zephyr modules are at the same place.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index f51689b..e2c649e 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -9,7 +9,7 @@ set(ZEPHYR_MODULES
"${CMAKE_CURRENT_SOURCE_DIR}/rtos/modules/cmsis"
"${CMAKE_CURRENT_SOURCE_DIR}/rtos/modules/stm32"
"${CMAKE_CURRENT_SOURCE_DIR}/rtos/modules/mbedtls"
- "${CMAKE_CURRENT_SOURCE_DIR}/btl/mcuboot"
+ "${CMAKE_CURRENT_SOURCE_DIR}/rtos/modules/mcuboot"
)
set(ZEPHYR_BASE "${CMAKE_CURRENT_SOURCE_DIR}/rtos/zephyr")
@@ -18,7 +18,7 @@ include(ExternalProject)
ExternalProject_Add(
btl
PREFIX btl
- SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/btl/mcuboot/boot/zephyr"
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/rtos/modules/mcuboot/boot/zephyr"
BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/btl"
INSTALL_COMMAND ""
LIST_SEPARATOR ","