summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-21 22:39:30 +0100
committerxengineering <me@xengineering.eu>2025-03-21 22:39:30 +0100
commit2ddf4682f4c11f4356b030b6474fb12fea55b8ea (patch)
treed71f952f46808d725da6f0e84dac765385df2ca1 /fw/CMakeLists.txt
parente042129eddeb06c9272a6544c67f9222c347ab10 (diff)
downloadiot-contact-2ddf4682f4c11f4356b030b6474fb12fea55b8ea.tar
iot-contact-2ddf4682f4c11f4356b030b6474fb12fea55b8ea.tar.zst
iot-contact-2ddf4682f4c11f4356b030b6474fb12fea55b8ea.zip
fw: js: Add web frontend to display heartbeat
This makes it transparent to the user that there is an active connection to the firmware. If the connection is broken the user notices that quickly and can re-load the page.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 5aaf319..5a8d6c4 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -39,3 +39,10 @@ generate_inc_file_for_target(
${ZEPHYR_BINARY_DIR}/include/generated/index.html.gz.inc
--gzip
)
+
+generate_inc_file_for_target(
+ app
+ src/iot-contact.js
+ ${ZEPHYR_BINARY_DIR}/include/generated/iot-contact.js.gz.inc
+ --gzip
+)