summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-02-11 06:58:50 +0100
committerxengineering <me@xengineering.eu>2025-02-11 06:58:50 +0100
commit304e1e443dc1283efbd1fe8b4a72c13f6cfc2fe4 (patch)
treed116911b7876abc796eee4ae649c3d6749c525c5 /fw/CMakeLists.txt
parent2c18a99bd24ddadd165eeabe5299ac094b0c0ee3 (diff)
downloadiot-contact-304e1e443dc1283efbd1fe8b4a72c13f6cfc2fe4.tar
iot-contact-304e1e443dc1283efbd1fe8b4a72c13f6cfc2fe4.tar.zst
iot-contact-304e1e443dc1283efbd1fe8b4a72c13f6cfc2fe4.zip
fw: Move content of `firmware` here
This makes the name shorter which is especially relevant for Git commit messages.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
new file mode 100644
index 0000000..b0093d0
--- /dev/null
+++ b/fw/CMakeLists.txt
@@ -0,0 +1,9 @@
+cmake_minimum_required(VERSION 3.20.0)
+
+set(BOARD "nucleo_f767zi")
+set(ZEPHYR_MODULES
+ "${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/modules/hal/cmsis;${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/modules/hal/stm32")
+find_package(Zephyr REQUIRED HINTS "${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/zephyr")
+project(iot-contact)
+
+target_sources(app PRIVATE src/main.c)