summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-22 21:39:13 +0100
committerxengineering <me@xengineering.eu>2025-03-22 22:30:41 +0100
commit62be0c0585b147686ad3a41fdce181c8a7e95cd1 (patch)
treec59339340f5b9fd405acc7e6c2a90380299f6bd0 /fw/CMakeLists.txt
parent09722ba833f4af39dc9b5894de15c1e823cb6ea8 (diff)
downloadiot-contact-62be0c0585b147686ad3a41fdce181c8a7e95cd1.tar
iot-contact-62be0c0585b147686ad3a41fdce181c8a7e95cd1.tar.zst
iot-contact-62be0c0585b147686ad3a41fdce181c8a7e95cd1.zip
fw: btl: Move MCUboot build here
The directory structure should be less nested and with shorter paths. This is a first step.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 1b978b7..6be1c21 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -9,7 +9,7 @@ set(ZEPHYR_MODULES
"${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/modules/hal/cmsis"
"${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/modules/hal/stm32"
"${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/modules/crypto/mbedtls"
- "${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/bootloader/mcuboot"
+ "${CMAKE_CURRENT_SOURCE_DIR}/btl/mcuboot"
)
string(REPLACE ";" "," ZEPHYR_MODULES_COMMA "${ZEPHYR_MODULES}")
@@ -17,14 +17,14 @@ include(ExternalProject)
ExternalProject_Add(
bootloader
PREFIX bootloader
- SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/bootloader/mcuboot/boot/zephyr"
- BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/bootloader"
+ SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/btl/mcuboot/boot/zephyr"
+ BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/btl"
INSTALL_COMMAND ""
LIST_SEPARATOR ","
CMAKE_ARGS
"-DBOARD=nucleo_f767zi"
"-DZEPHYR_MODULES=${ZEPHYR_MODULES_COMMA}"
- "-DEXTRA_CONF_FILE=${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/bootloader/bootloader.conf"
+ "-DEXTRA_CONF_FILE=${CMAKE_CURRENT_SOURCE_DIR}/btl/bootloader.conf"
-DCONFIG_BOOT_SIGNATURE_KEY_FILE="${KEY}"
)