summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-02-24 20:36:52 +0100
committerxengineering <me@xengineering.eu>2025-02-24 20:40:46 +0100
commit8563e7bdf4d4be63e52601b0fbd5557e28561454 (patch)
tree87eda04d461ecba8b51d86f41adc2ba36cd70518 /fw/CMakeLists.txt
parent5099b9846dcd8c62a877140f99936ea8f7101e4e (diff)
downloadiot-contact-8563e7bdf4d4be63e52601b0fbd5557e28561454.tar
iot-contact-8563e7bdf4d4be63e52601b0fbd5557e28561454.tar.zst
iot-contact-8563e7bdf4d4be63e52601b0fbd5557e28561454.zip
fw: Use custom MCUboot signing key
Using the MCUboot default key adds nearly not security at all.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
index 8c229e0..1d90178 100644
--- a/fw/CMakeLists.txt
+++ b/fw/CMakeLists.txt
@@ -24,6 +24,8 @@ ExternalProject_Add(
CMAKE_ARGS
"-DBOARD=${BOARD}"
"-DZEPHYR_MODULES=${ZEPHYR_MODULES_COMMA}"
+ "-DEXTRA_CONF_FILE=${CMAKE_CURRENT_SOURCE_DIR}/zephyrproject/bootloader/bootloader.conf"
+ -DCONFIG_BOOT_SIGNATURE_KEY_FILE="${KEY}"
)
find_package(Zephyr