summaryrefslogtreecommitdiff
path: root/fw/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-06 20:02:56 +0200
committerxengineering <me@xengineering.eu>2025-04-06 20:02:56 +0200
commitee1dea051b0a43c02cf56dfc6a812c1a32910bc6 (patch)
tree6f555191efc74f7ada207990a233466e953175b8 /fw/CMakeLists.txt
parentd19fc7e34f783b343e77b757c4f37aaadb5b66ca (diff)
parentda27d61588202d6b460e36d29a8789d206495bd6 (diff)
downloadiot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.tar
iot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.tar.zst
iot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.zip
Merge website and CMake to Meson transition
Building a website to structure and deploy the artifacts was planned and requires a well set-up build system to handle all the file paths targets and dependencies. Since multiple CMake Zephyr builds are required for the application firmware, bootloader firmware and the native_sim application firmware simulation CMake external project was used. Since this generates a build tree with a confusing structure Meson was evaluated. Finally the Meson build system was a good fit as top-level build system and allows external projects as an experimental feature if they can configure a Make-based build system which is given for Zephyr.
Diffstat (limited to 'fw/CMakeLists.txt')
-rw-r--r--fw/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/fw/CMakeLists.txt b/fw/CMakeLists.txt
deleted file mode 100644
index 2affe92..0000000
--- a/fw/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
-# This Source Code Form is subject to the terms of the Mozilla Public License,
-# v. 2.0. If a copy of the MPL was not distributed with this file, You can
-# obtain one at https://mozilla.org/MPL/2.0/.
-
-cmake_minimum_required(VERSION 3.20.0)
-
-include(ExternalProject)
-
-set(KEY_DEFAULT "$ENV{HOME}/mcuboot/key.pem")
-set(KEY ${KEY_DEFAULT} CACHE STRING "Firmware signing key path")
-message(STATUS "Firmware signing key path: ${KEY}")
-
-set(BOARD_DEFAULT "native_sim/native/64")
-set(BOARD ${BOARD_DEFAULT} CACHE STRING "Zephyr board identifier")
-message(STATUS "Selected board: ${BOARD}")
-
-add_subdirectory(rtos)
-string(REPLACE ";" "," ZEPHYR_MODULES_COMMA "${ZEPHYR_MODULES}")
-
-if(BOARD STREQUAL "nucleo_f767zi")
- ExternalProject_Add(
- btl
- PREFIX btl
- SOURCE_DIR "${CMAKE_CURRENT_SOURCE_DIR}/rtos/modules/mcuboot/boot/zephyr"
- BINARY_DIR "${CMAKE_CURRENT_BINARY_DIR}/btl"
- INSTALL_COMMAND ""
- LIST_SEPARATOR ","
- CMAKE_ARGS
- "-DBOARD=${BOARD}"
- "-DZEPHYR_BASE=${ZEPHYR_BASE}"
- "-DZEPHYR_MODULES=${ZEPHYR_MODULES_COMMA}"
- "-DEXTRA_CONF_FILE=${CMAKE_CURRENT_SOURCE_DIR}/btl/bootloader.conf"
- -DCONFIG_BOOT_SIGNATURE_KEY_FILE="${KEY}"
- )
-endif()
-
-add_subdirectory(app)