summaryrefslogtreecommitdiff
path: root/fw/app/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-12 12:11:33 +0200
committerxengineering <me@xengineering.eu>2025-04-12 12:11:33 +0200
commit3b857fd34c9e92eed346b7ea73706f50a193fe14 (patch)
tree39c72df3f1a18fc6ab7b513116afd5d460e1ff87 /fw/app/CMakeLists.txt
parentddcf8559d4fbb9bd6942ac46d5c4970ef08b16d1 (diff)
downloadiot-contact-3b857fd34c9e92eed346b7ea73706f50a193fe14.tar
iot-contact-3b857fd34c9e92eed346b7ea73706f50a193fe14.tar.zst
iot-contact-3b857fd34c9e92eed346b7ea73706f50a193fe14.zip
fw: app: Re-design web page
This enables simple.css also for the device-hosted website and restructures the HTML a bit.
Diffstat (limited to 'fw/app/CMakeLists.txt')
-rw-r--r--fw/app/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/fw/app/CMakeLists.txt b/fw/app/CMakeLists.txt
index 1a9d1cf..1a63b77 100644
--- a/fw/app/CMakeLists.txt
+++ b/fw/app/CMakeLists.txt
@@ -42,6 +42,13 @@ generate_inc_file_for_target(
generate_inc_file_for_target(
app
+ src/simple.css
+ ${ZEPHYR_BINARY_DIR}/include/generated/simple.css.gz.inc
+ --gzip
+)
+
+generate_inc_file_for_target(
+ app
src/iot-contact.js
${ZEPHYR_BINARY_DIR}/include/generated/iot-contact.js.gz.inc
--gzip