summaryrefslogtreecommitdiff
path: root/fw/app/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-07 19:52:37 +0200
committerxengineering <me@xengineering.eu>2025-05-07 19:58:14 +0200
commit46b537fb86e029978d9a1f8aa5d07ec2949ea7a1 (patch)
tree71ef55ce4a9862d57bdc401c739363fb9f99894b /fw/app/meson.build
parenta5aafcbd0398ae3893a83827cf66d4352eaee8f0 (diff)
downloadiot-contact-improve-buildsystem.tar
iot-contact-improve-buildsystem.tar.zst
iot-contact-improve-buildsystem.zip
WIP: Remove installation stepimprove-buildsystem
TODO: Check if the bootloader install target is still usable. Using the installation step to copy selected artifacts into on folder was anyway a hack. This commit shows that the complexity can be reduced by adding copy targets. The `build/artifacts` folder contains the selected artifacts, they are always up to date, the user does not have to call the install step separately and the target definitions do not require install-related keyword arguments.
Diffstat (limited to 'fw/app/meson.build')
-rw-r--r--fw/app/meson.build4
1 files changed, 0 insertions, 4 deletions
diff --git a/fw/app/meson.build b/fw/app/meson.build
index ddd5aa6..0aefcb3 100644
--- a/fw/app/meson.build
+++ b/fw/app/meson.build
@@ -15,7 +15,6 @@ external_project.add_project(
)
application = custom_target(
- 'application',
output: ['application.bin'],
command: [
build_zephyr,
@@ -26,7 +25,6 @@ application = custom_target(
)
application_signed = custom_target(
- 'application_signed',
output: ['application.signed.bin'],
command: [
imgtool,
@@ -40,8 +38,6 @@ application_signed = custom_target(
],
build_by_default: true,
depends: application,
- install: true,
- install_dir: '/',
)
flash_application = custom_target(