summaryrefslogtreecommitdiff
path: root/fw/app/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-24 11:20:28 +0200
committerxengineering <me@xengineering.eu>2025-05-24 11:20:28 +0200
commitbf8d20fe4d8d3369dd7f63e95f53613dbbfa3603 (patch)
tree539d4610508c1bb3069c5f11ee63977e534b2a68 /fw/app/meson.build
parent4af0ed8242ab24b2b222a9ebbf417e12f608b756 (diff)
downloadiot-contact-bf8d20fe4d8d3369dd7f63e95f53613dbbfa3603.tar
iot-contact-bf8d20fe4d8d3369dd7f63e95f53613dbbfa3603.tar.zst
iot-contact-bf8d20fe4d8d3369dd7f63e95f53613dbbfa3603.zip
artifacts: Provide `{factory,update}-image.bin`
This presents only the `factory-image.bin` and `update-image.bin` for MCU firmware. A separate bootloader image is not available. The reason is that the `factory-image.bin` is used during production once (flashing at default boot address) to set up the device. Later only the `update-image.bin` of future versions would be required to remotely update devices.
Diffstat (limited to 'fw/app/meson.build')
-rw-r--r--fw/app/meson.build4
1 files changed, 2 insertions, 2 deletions
diff --git a/fw/app/meson.build b/fw/app/meson.build
index 27b4a41..6665fe4 100644
--- a/fw/app/meson.build
+++ b/fw/app/meson.build
@@ -28,8 +28,8 @@ version = '0.0.0'
header_size = '0x200'
slot_size = '0xc0000'
-application_signed = custom_target(
- output: ['application.signed.bin'],
+update_image = custom_target(
+ output: ['update-image.bin'],
command: [
imgtool,
'sign',