summaryrefslogtreecommitdiff
path: root/fw/btl/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-07 19:52:37 +0200
committerxengineering <me@xengineering.eu>2025-05-07 19:58:14 +0200
commit46b537fb86e029978d9a1f8aa5d07ec2949ea7a1 (patch)
tree71ef55ce4a9862d57bdc401c739363fb9f99894b /fw/btl/meson.build
parenta5aafcbd0398ae3893a83827cf66d4352eaee8f0 (diff)
downloadiot-contact-improve-buildsystem.tar
iot-contact-improve-buildsystem.tar.zst
iot-contact-improve-buildsystem.zip
WIP: Remove installation stepimprove-buildsystem
TODO: Check if the bootloader install target is still usable. Using the installation step to copy selected artifacts into on folder was anyway a hack. This commit shows that the complexity can be reduced by adding copy targets. The `build/artifacts` folder contains the selected artifacts, they are always up to date, the user does not have to call the install step separately and the target definitions do not require install-related keyword arguments.
Diffstat (limited to 'fw/btl/meson.build')
-rw-r--r--fw/btl/meson.build4
1 files changed, 1 insertions, 3 deletions
diff --git a/fw/btl/meson.build b/fw/btl/meson.build
index 8ca1eb3..b86c9c9 100644
--- a/fw/btl/meson.build
+++ b/fw/btl/meson.build
@@ -14,7 +14,7 @@ external_project.add_project(
verbose: true,
)
-bootloader = custom_target('bootloader',
+bootloader = custom_target(
output: ['bootloader.bin'],
command: [
build_zephyr,
@@ -23,8 +23,6 @@ bootloader = custom_target('bootloader',
'--target-name', 'bootloader.bin',
],
build_by_default: true,
- install: true,
- install_dir: '/',
)
flash_bootloader = custom_target(