summaryrefslogtreecommitdiff
path: root/fw/btl/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-06 13:38:24 +0200
committerxengineering <me@xengineering.eu>2025-04-06 13:39:29 +0200
commit9f75ad79c0df9035bcdfd11011ba475cc80ad50a (patch)
tree47ec9c6a0367b4790f8cb4da08979159492f138e /fw/btl/meson.build
parent28576b0bdb6b6e08b186c2919bbed4393b38bb7f (diff)
downloadiot-contact-9f75ad79c0df9035bcdfd11011ba475cc80ad50a.tar
iot-contact-9f75ad79c0df9035bcdfd11011ba475cc80ad50a.tar.zst
iot-contact-9f75ad79c0df9035bcdfd11011ba475cc80ad50a.zip
fw: btl: Configure with Python script
To use a more readable scripting language and keep portability the POSIX shell script for Zephyr configuration is replaced by Python.
Diffstat (limited to 'fw/btl/meson.build')
-rw-r--r--fw/btl/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/fw/btl/meson.build b/fw/btl/meson.build
index 08399a9..0b48c11 100644
--- a/fw/btl/meson.build
+++ b/fw/btl/meson.build
@@ -2,7 +2,7 @@ bootloader_config = meson.current_source_dir() / 'bootloader.conf'
external_project = import('unstable-external_project')
bootloader_bin = meson.current_build_dir() / 'zephyr' / 'zephyr.bin'
-bootloader_project = external_project.add_project('configure.sh',
+bootloader_project = external_project.add_project('configure.py',
configure_options: [
bootloader_firmware,
meson.current_build_dir() / 'build',