summaryrefslogtreecommitdiff
path: root/fw/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-24 11:20:08 +0200
committerxengineering <me@xengineering.eu>2025-05-24 11:20:08 +0200
commitfc3b3cbf7fecee7226f249f7b62cf36aa82a545a (patch)
tree2f3ebc06ecc4ed786139966d70e1b6105748e505 /fw/meson.build
parent072c1d0208b267abf6a573ad5d2482113d9c9cee (diff)
downloadiot-contact-fc3b3cbf7fecee7226f249f7b62cf36aa82a545a.tar
iot-contact-fc3b3cbf7fecee7226f249f7b62cf36aa82a545a.tar.zst
iot-contact-fc3b3cbf7fecee7226f249f7b62cf36aa82a545a.zip
Provide `factory-image.bin` with Meson
This automatically creates `build/artifacts/factory-image.bin` with the Meson build system. The resulting file can simply be moved to the virtual file system of the `nucleo_f767zi` board to flash bootloader and application making the board ready for operation and remote updates.
Diffstat (limited to 'fw/meson.build')
-rw-r--r--fw/meson.build14
1 files changed, 14 insertions, 0 deletions
diff --git a/fw/meson.build b/fw/meson.build
index 8194827..8f45d5b 100644
--- a/fw/meson.build
+++ b/fw/meson.build
@@ -7,3 +7,17 @@ subdir('rtos')
subdir('app')
subdir('btl')
subdir('sim')
+
+factory_image = custom_target(
+ output: ['factory-image.bin'],
+ command: [
+ make_factory_image,
+ '--bootloader', bootloader,
+ '--application', application_signed_confirmed,
+ '--factory-image', '@OUTPUT@',
+ ],
+ depends: [
+ bootloader,
+ application_signed_confirmed,
+ ],
+)