summaryrefslogtreecommitdiff
path: root/fw/rtos/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-03-26 20:59:54 +0100
committerxengineering <me@xengineering.eu>2025-03-26 21:18:23 +0100
commit2b7ecfb1f5b6c9f98d239c893d4b4130176a1beb (patch)
tree73d8018e916574536a20ed4c85a2a4f16a82a856 /fw/rtos/CMakeLists.txt
parent7c73e4958f3be36ee80ae978d7c52db15949954b (diff)
downloadiot-contact-2b7ecfb1f5b6c9f98d239c893d4b4130176a1beb.tar
iot-contact-2b7ecfb1f5b6c9f98d239c893d4b4130176a1beb.tar.zst
iot-contact-2b7ecfb1f5b6c9f98d239c893d4b4130176a1beb.zip
fw: rtos: Add CMakeLists.txt
This moves the definition of ZEPHYR_MODULES and ZEPHYR_BASE to this rtos folder where it fits best.
Diffstat (limited to 'fw/rtos/CMakeLists.txt')
-rw-r--r--fw/rtos/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/fw/rtos/CMakeLists.txt b/fw/rtos/CMakeLists.txt
new file mode 100644
index 0000000..d9f116c
--- /dev/null
+++ b/fw/rtos/CMakeLists.txt
@@ -0,0 +1,16 @@
+# This Source Code Form is subject to the terms of the Mozilla Public License,
+# v. 2.0. If a copy of the MPL was not distributed with this file, You can
+# obtain one at https://mozilla.org/MPL/2.0/.
+
+set(ZEPHYR_MODULES
+ "${CMAKE_CURRENT_SOURCE_DIR}/modules/cmsis"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modules/hal_stm32"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modules/mbedtls"
+ "${CMAKE_CURRENT_SOURCE_DIR}/modules/mcuboot"
+ PARENT_SCOPE
+)
+
+set(ZEPHYR_BASE
+ "${CMAKE_CURRENT_SOURCE_DIR}/zephyr"
+ PARENT_SCOPE
+)