summaryrefslogtreecommitdiff
path: root/fw/rtos/modules/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-05 11:10:12 +0200
committerxengineering <me@xengineering.eu>2025-04-05 15:33:09 +0200
commit82fa02bcac5e278586cb2e3c9cc597699f6f640d (patch)
tree4a6bfc82f3f94fadd7c3717633203ed64e1f0495 /fw/rtos/modules/meson.build
parent00189e737517f4470336d819d52327a037509493 (diff)
downloadiot-contact-82fa02bcac5e278586cb2e3c9cc597699f6f640d.tar
iot-contact-82fa02bcac5e278586cb2e3c9cc597699f6f640d.tar.zst
iot-contact-82fa02bcac5e278586cb2e3c9cc597699f6f640d.zip
fw: btl: Configure bootloader build with Meson
CMake ExternalProject creates a pretty confusing build tree. Since the rest of the project anyway starts moving to Meson the bootloader is configured via Meson as a first step.
Diffstat (limited to 'fw/rtos/modules/meson.build')
-rw-r--r--fw/rtos/modules/meson.build8
1 files changed, 8 insertions, 0 deletions
diff --git a/fw/rtos/modules/meson.build b/fw/rtos/modules/meson.build
new file mode 100644
index 0000000..52f50c2
--- /dev/null
+++ b/fw/rtos/modules/meson.build
@@ -0,0 +1,8 @@
+zephyr_modules = [
+ meson.current_source_dir() / 'cmsis',
+ meson.current_source_dir() / 'hal_stm32',
+ meson.current_source_dir() / 'mbedtls',
+ meson.current_source_dir() / 'mcuboot',
+]
+
+bootloader_firmware = meson.current_source_dir() / 'mcuboot' / 'boot' / 'zephyr'