summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-07 19:52:37 +0200
committerxengineering <me@xengineering.eu>2025-05-07 19:58:14 +0200
commit46b537fb86e029978d9a1f8aa5d07ec2949ea7a1 (patch)
tree71ef55ce4a9862d57bdc401c739363fb9f99894b /meson.build
parenta5aafcbd0398ae3893a83827cf66d4352eaee8f0 (diff)
downloadiot-contact-improve-buildsystem.tar
iot-contact-improve-buildsystem.tar.zst
iot-contact-improve-buildsystem.zip
WIP: Remove installation stepimprove-buildsystem
TODO: Check if the bootloader install target is still usable. Using the installation step to copy selected artifacts into on folder was anyway a hack. This commit shows that the complexity can be reduced by adding copy targets. The `build/artifacts` folder contains the selected artifacts, they are always up to date, the user does not have to call the install step separately and the target definitions do not require install-related keyword arguments.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 6 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index eb7f9ad..9b7d7c1 100644
--- a/meson.build
+++ b/meson.build
@@ -1,20 +1,13 @@
-project(
- 'iot-contact',
- default_options: {
- 'prefix': '/',
- },
-)
+project('iot-contact')
-subdir('tools')
+cp = find_program('cp', required : true)
fs = import('fs')
-css = fs.copyfile(
- meson.current_source_dir() / 'simple.css' / 'simple.css',
- 'simple.css',
- install: true,
- install_dir: '/',
-)
+css = fs.copyfile(meson.current_source_dir() / 'simple.css' / 'simple.css')
+
+subdir('tools')
subdir('fw')
subdir('pcb')
subdir('web')
+subdir('artifacts')