summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-05 15:28:04 +0200
committerxengineering <me@xengineering.eu>2025-04-05 15:28:04 +0200
commit00189e737517f4470336d819d52327a037509493 (patch)
tree8f7d2f3e616a89b807cf2986ecc6ee6876f99392 /meson.build
parent061a67ea6e4a7fb9658fd3efc1c670eae5ff3eb6 (diff)
downloadiot-contact-00189e737517f4470336d819d52327a037509493.tar
iot-contact-00189e737517f4470336d819d52327a037509493.tar.zst
iot-contact-00189e737517f4470336d819d52327a037509493.zip
web: Replace file copying by Meson installation
This makes the build system code way less hacky and more modular.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build8
1 files changed, 7 insertions, 1 deletions
diff --git a/meson.build b/meson.build
index a0e6468..73206f4 100644
--- a/meson.build
+++ b/meson.build
@@ -1,6 +1,12 @@
project('iot-contact')
-css = meson.current_source_dir() / 'simple.css' / 'simple.css'
+fs = import('fs')
+css = fs.copyfile(
+ meson.current_source_dir() / 'simple.css' / 'simple.css',
+ 'simple.css',
+ install: true,
+ install_dir: 'website/static',
+)
subdir('pcb')
subdir('web')