summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-24 11:18:38 +0200
committerxengineering <me@xengineering.eu>2025-05-24 11:18:38 +0200
commitcaf416218623d6778b3d0c2fe12ee08135c2d126 (patch)
treeed255392f80eb2c692d585d86a78c1ac971db966 /meson.build
parentb1838d1c5b6bd27757d50d784543ea0ae16c1769 (diff)
downloadiot-contact-caf416218623d6778b3d0c2fe12ee08135c2d126.tar
iot-contact-caf416218623d6778b3d0c2fe12ee08135c2d126.tar.zst
iot-contact-caf416218623d6778b3d0c2fe12ee08135c2d126.zip
Remove installation step
Using the installation step to copy selected artifacts into one folder was anyway a hack. This commit shows that the complexity can be reduced by adding copy targets. The `build/artifacts` folder contains the selected artifacts, they are always up to date, the user does not have to call the install step separately and the target definitions do not require install-related keyword arguments.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build19
1 files changed, 6 insertions, 13 deletions
diff --git a/meson.build b/meson.build
index eb7f9ad..9b7d7c1 100644
--- a/meson.build
+++ b/meson.build
@@ -1,20 +1,13 @@
-project(
- 'iot-contact',
- default_options: {
- 'prefix': '/',
- },
-)
+project('iot-contact')
-subdir('tools')
+cp = find_program('cp', required : true)
fs = import('fs')
-css = fs.copyfile(
- meson.current_source_dir() / 'simple.css' / 'simple.css',
- 'simple.css',
- install: true,
- install_dir: '/',
-)
+css = fs.copyfile(meson.current_source_dir() / 'simple.css' / 'simple.css')
+
+subdir('tools')
subdir('fw')
subdir('pcb')
subdir('web')
+subdir('artifacts')