summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-06 17:27:49 +0200
committerxengineering <me@xengineering.eu>2025-04-06 17:27:49 +0200
commite78341079228b135bee65deb8e0d4e2b4385cf94 (patch)
tree2b6287e9fe31efc0335358d5cd3f95e3652117e9 /meson.build
parent04e504c94db921d45b63c7ea75389d692de6738e (diff)
downloadiot-contact-e78341079228b135bee65deb8e0d4e2b4385cf94.tar
iot-contact-e78341079228b135bee65deb8e0d4e2b4385cf94.tar.zst
iot-contact-e78341079228b135bee65deb8e0d4e2b4385cf94.zip
tools: Add directory and move scripts here
This allows to re-use these scripts. Since they are currently used to build Zephyr builds and three are intended (application, bootloader and application as native_sim build) this makes sense.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build4
1 files changed, 4 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 9205388..446fb29 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,9 @@
project('iot-contact')
+tools = meson.current_source_dir() / 'tools'
+configure_zephyr = tools / 'configure_zephyr.py'
+build_zephyr = tools / 'build_zephyr.py'
+
fs = import('fs')
css = fs.copyfile(
meson.current_source_dir() / 'simple.css' / 'simple.css',