summaryrefslogtreecommitdiff
path: root/pcb/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-02-14 14:26:24 +0100
committerxengineering <me@xengineering.eu>2025-02-14 14:26:24 +0100
commit4e31ee88f737d593277c10530e980ab8ab2715c5 (patch)
treea97dc87d780030c65520f1fed3a209a1a7fb6c45 /pcb/CMakeLists.txt
parenteae277aba525a3350729e63895d2aabc03a4ffa5 (diff)
downloadiot-contact-4e31ee88f737d593277c10530e980ab8ab2715c5.tar
iot-contact-4e31ee88f737d593277c10530e980ab8ab2715c5.tar.zst
iot-contact-4e31ee88f737d593277c10530e980ab8ab2715c5.zip
pcb: Add CMake and export schematic by default
Diffstat (limited to 'pcb/CMakeLists.txt')
-rw-r--r--pcb/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/pcb/CMakeLists.txt b/pcb/CMakeLists.txt
new file mode 100644
index 0000000..1881157
--- /dev/null
+++ b/pcb/CMakeLists.txt
@@ -0,0 +1,8 @@
+cmake_minimum_required(VERSION 3.10)
+
+project(iot-contact-pcb LANGUAGES NONE)
+
+include(kicad)
+
+set(schematic "${CMAKE_CURRENT_SOURCE_DIR}/iot-contact.kicad_sch")
+kicad_schematic_to_pdf("${schematic}" "pcb-schematic-pdf")