summaryrefslogtreecommitdiff
path: root/pcb/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-05 09:52:41 +0200
committerxengineering <me@xengineering.eu>2025-04-05 10:47:40 +0200
commit6ff99393b4bbc1207375cbbc032814e233b03758 (patch)
treeca4f3488b8d327963c135640ba2695bfcb9c3aa8 /pcb/CMakeLists.txt
parentb7c46986ac3aa4a17b9fac2ad54afec9d6a3506f (diff)
downloadiot-contact-6ff99393b4bbc1207375cbbc032814e233b03758.tar
iot-contact-6ff99393b4bbc1207375cbbc032814e233b03758.tar.zst
iot-contact-6ff99393b4bbc1207375cbbc032814e233b03758.zip
pcb: Switch from CMake to Meson
This allows to install the PCB-related files easier to the website which is built with Meson.
Diffstat (limited to 'pcb/CMakeLists.txt')
-rw-r--r--pcb/CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/pcb/CMakeLists.txt b/pcb/CMakeLists.txt
deleted file mode 100644
index 8d2c49a..0000000
--- a/pcb/CMakeLists.txt
+++ /dev/null
@@ -1,21 +0,0 @@
-cmake_minimum_required(VERSION 3.10)
-
-project(iot-contact-pcb LANGUAGES NONE)
-
-include(kicad)
-
-set_property(GLOBAL PROPERTY JOB_POOLS kicad=1)
-
-set(schematic "${CMAKE_CURRENT_SOURCE_DIR}/iot-contact.kicad_sch")
-
-kicad_schematic_pdf(
- "schematic"
- "${CMAKE_CURRENT_BINARY_DIR}/schematic.pdf"
- "${schematic}"
-)
-
-kicad_bom_csv(
- "bom"
- "${CMAKE_CURRENT_BINARY_DIR}/bom.csv"
- "${schematic}"
-)