summaryrefslogtreecommitdiff
path: root/pcb/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-05 15:28:04 +0200
committerxengineering <me@xengineering.eu>2025-04-05 15:28:04 +0200
commit00189e737517f4470336d819d52327a037509493 (patch)
tree8f7d2f3e616a89b807cf2986ecc6ee6876f99392 /pcb/meson.build
parent061a67ea6e4a7fb9658fd3efc1c670eae5ff3eb6 (diff)
downloadiot-contact-00189e737517f4470336d819d52327a037509493.tar
iot-contact-00189e737517f4470336d819d52327a037509493.tar.zst
iot-contact-00189e737517f4470336d819d52327a037509493.zip
web: Replace file copying by Meson installation
This makes the build system code way less hacky and more modular.
Diffstat (limited to 'pcb/meson.build')
-rw-r--r--pcb/meson.build12
1 files changed, 6 insertions, 6 deletions
diff --git a/pcb/meson.build b/pcb/meson.build
index d74f8c3..7f8b85f 100644
--- a/pcb/meson.build
+++ b/pcb/meson.build
@@ -7,7 +7,6 @@ schematic_files = [
'processor.kicad_sch',
]
-schematic_pdf = meson.current_build_dir() / 'schematic.pdf'
schematic = custom_target('schematic',
output: ['schematic.pdf'],
command: [
@@ -15,14 +14,15 @@ schematic = custom_target('schematic',
'sch',
'export',
'pdf',
- '--output', schematic_pdf,
+ '--output', meson.current_build_dir() / 'schematic.pdf',
meson.current_source_dir() / 'iot-contact.kicad_sch',
],
depend_files: schematic_files,
build_by_default: true,
+ install: true,
+ install_dir: 'website/static',
)
-bom_csv = meson.current_build_dir() / 'bill-of-materials.csv'
bom = custom_target('bom',
output: ['bill-of-materials.csv'],
command: [
@@ -32,11 +32,11 @@ bom = custom_target('bom',
'bom',
'--fields',
'Reference,Description,Value,Footprint,Manufacturer,MPN,Datasheet',
- '--output', bom_csv,
+ '--output', meson.current_build_dir() / 'bill-of-materials.csv',
meson.current_source_dir() / 'iot-contact.kicad_sch',
],
depend_files: schematic_files,
build_by_default: true,
+ install: true,
+ install_dir: 'website/static',
)
-
-pcb = meson.current_build_dir()