summaryrefslogtreecommitdiff
path: root/pcb/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-24 11:31:11 +0200
committerxengineering <me@xengineering.eu>2025-05-24 11:31:11 +0200
commita82bdbbec681cec0c6f5304318b6010f1752dbf6 (patch)
tree539d4610508c1bb3069c5f11ee63977e534b2a68 /pcb/meson.build
parentf38300b15627e5234f0f0a07c31c32135901dee7 (diff)
parentbf8d20fe4d8d3369dd7f63e95f53613dbbfa3603 (diff)
downloadiot-contact-a82bdbbec681cec0c6f5304318b6010f1752dbf6.tar
iot-contact-a82bdbbec681cec0c6f5304318b6010f1752dbf6.tar.zst
iot-contact-a82bdbbec681cec0c6f5304318b6010f1752dbf6.zip
Merge build system improvements
- remove flash targets (replaced by easy to flash `factory-image.bin`) - replaced installation step by copy targets - provide `factory-image.bin` and `update-image.bin`
Diffstat (limited to 'pcb/meson.build')
-rw-r--r--pcb/meson.build8
1 files changed, 2 insertions, 6 deletions
diff --git a/pcb/meson.build b/pcb/meson.build
index f320aae..293b2a1 100644
--- a/pcb/meson.build
+++ b/pcb/meson.build
@@ -7,7 +7,7 @@ schematic_files = [
'processor.kicad_sch',
]
-schematic = custom_target('schematic',
+schematic = custom_target(
output: ['schematic.pdf'],
command: [
'kicad-cli',
@@ -19,11 +19,9 @@ schematic = custom_target('schematic',
],
depend_files: schematic_files,
build_by_default: true,
- install: true,
- install_dir: '/',
)
-bom = custom_target('bom',
+bom = custom_target(
output: ['bill-of-materials.csv'],
command: [
'kicad-cli',
@@ -37,6 +35,4 @@ bom = custom_target('bom',
],
depend_files: schematic_files,
build_by_default: true,
- install: true,
- install_dir: '/',
)