summaryrefslogtreecommitdiff
path: root/pcb/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-06 20:02:56 +0200
committerxengineering <me@xengineering.eu>2025-04-06 20:02:56 +0200
commitee1dea051b0a43c02cf56dfc6a812c1a32910bc6 (patch)
tree6f555191efc74f7ada207990a233466e953175b8 /pcb/meson.build
parentd19fc7e34f783b343e77b757c4f37aaadb5b66ca (diff)
parentda27d61588202d6b460e36d29a8789d206495bd6 (diff)
downloadiot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.tar
iot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.tar.zst
iot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.zip
Merge website and CMake to Meson transition
Building a website to structure and deploy the artifacts was planned and requires a well set-up build system to handle all the file paths targets and dependencies. Since multiple CMake Zephyr builds are required for the application firmware, bootloader firmware and the native_sim application firmware simulation CMake external project was used. Since this generates a build tree with a confusing structure Meson was evaluated. Finally the Meson build system was a good fit as top-level build system and allows external projects as an experimental feature if they can configure a Make-based build system which is given for Zephyr.
Diffstat (limited to 'pcb/meson.build')
-rw-r--r--pcb/meson.build42
1 files changed, 42 insertions, 0 deletions
diff --git a/pcb/meson.build b/pcb/meson.build
new file mode 100644
index 0000000..7f8b85f
--- /dev/null
+++ b/pcb/meson.build
@@ -0,0 +1,42 @@
+schematic_files = [
+ 'iot-contact.kicad_sch',
+ 'contacts.kicad_sch',
+ 'ethernet.kicad_sch',
+ 'io.kicad_sch',
+ 'power.kicad_sch',
+ 'processor.kicad_sch',
+]
+
+schematic = custom_target('schematic',
+ output: ['schematic.pdf'],
+ command: [
+ 'kicad-cli',
+ 'sch',
+ 'export',
+ 'pdf',
+ '--output', meson.current_build_dir() / 'schematic.pdf',
+ meson.current_source_dir() / 'iot-contact.kicad_sch',
+ ],
+ depend_files: schematic_files,
+ build_by_default: true,
+ install: true,
+ install_dir: 'website/static',
+)
+
+bom = custom_target('bom',
+ output: ['bill-of-materials.csv'],
+ command: [
+ 'kicad-cli',
+ 'sch',
+ 'export',
+ 'bom',
+ '--fields',
+ 'Reference,Description,Value,Footprint,Manufacturer,MPN,Datasheet',
+ '--output', meson.current_build_dir() / 'bill-of-materials.csv',
+ meson.current_source_dir() / 'iot-contact.kicad_sch',
+ ],
+ depend_files: schematic_files,
+ build_by_default: true,
+ install: true,
+ install_dir: 'website/static',
+)