summaryrefslogtreecommitdiff
path: root/pcb/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-11 17:54:26 +0200
committerxengineering <me@xengineering.eu>2025-04-11 17:54:26 +0200
commitf3129be277c4a633c63ee9f4b12cdb2b63d8130c (patch)
tree37d4b67affa6b4a2a353b1e263d748544f24a20d /pcb/meson.build
parentd9a9ea56e6b733a6b054e662d5d4b0ce015a219c (diff)
downloadiot-contact-f3129be277c4a633c63ee9f4b12cdb2b63d8130c.tar
iot-contact-f3129be277c4a633c63ee9f4b12cdb2b63d8130c.tar.zst
iot-contact-f3129be277c4a633c63ee9f4b12cdb2b63d8130c.zip
web: Deploy iot-contact.kicad_pcb
This can be used to order the PCB depending on the manufacturers software capabilities.
Diffstat (limited to 'pcb/meson.build')
-rw-r--r--pcb/meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/pcb/meson.build b/pcb/meson.build
index f320aae..2c73e57 100644
--- a/pcb/meson.build
+++ b/pcb/meson.build
@@ -40,3 +40,10 @@ bom = custom_target('bom',
install: true,
install_dir: '/',
)
+
+fs = import('fs')
+kicad_pcb = fs.copyfile(
+ meson.current_source_dir() / 'iot-contact.kicad_pcb',
+ install: true,
+ install_dir: '/',
+)