summaryrefslogtreecommitdiff
path: root/web/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-01 21:30:21 +0200
committerxengineering <me@xengineering.eu>2025-04-01 21:30:33 +0200
commitc0b343a13a042465e2756caf5ac1cd126800d682 (patch)
treeb7ff9f1a41ac632c1d105c14460172ac4c7ae7f6 /web/CMakeLists.txt
parent6de625f514cbf6ea8dbb508d791fc4cbd7debe22 (diff)
downloadiot-contact-c0b343a13a042465e2756caf5ac1cd126800d682.tar
iot-contact-c0b343a13a042465e2756caf5ac1cd126800d682.tar.zst
iot-contact-c0b343a13a042465e2756caf5ac1cd126800d682.zip
web: Embed into CMake build
The website should be part of the regular CMake build for convenience. Later the dependencies might be set up in a way that the site automatically and incrementally updates with a ninja call.
Diffstat (limited to 'web/CMakeLists.txt')
-rw-r--r--web/CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/web/CMakeLists.txt b/web/CMakeLists.txt
new file mode 100644
index 0000000..0cdb498
--- /dev/null
+++ b/web/CMakeLists.txt
@@ -0,0 +1,9 @@
+cmake_minimum_required(VERSION 3.10)
+
+include(hugo)
+
+hugo_site(
+ "website"
+ "${CMAKE_CURRENT_SOURCE_DIR}"
+ "${CMAKE_CURRENT_BINARY_DIR}/public"
+)