summaryrefslogtreecommitdiff
path: root/web/CMakeLists.txt
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-06 20:02:56 +0200
committerxengineering <me@xengineering.eu>2025-04-06 20:02:56 +0200
commitee1dea051b0a43c02cf56dfc6a812c1a32910bc6 (patch)
tree6f555191efc74f7ada207990a233466e953175b8 /web/CMakeLists.txt
parentd19fc7e34f783b343e77b757c4f37aaadb5b66ca (diff)
parentda27d61588202d6b460e36d29a8789d206495bd6 (diff)
downloadiot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.tar
iot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.tar.zst
iot-contact-ee1dea051b0a43c02cf56dfc6a812c1a32910bc6.zip
Merge website and CMake to Meson transition
Building a website to structure and deploy the artifacts was planned and requires a well set-up build system to handle all the file paths targets and dependencies. Since multiple CMake Zephyr builds are required for the application firmware, bootloader firmware and the native_sim application firmware simulation CMake external project was used. Since this generates a build tree with a confusing structure Meson was evaluated. Finally the Meson build system was a good fit as top-level build system and allows external projects as an experimental feature if they can configure a Make-based build system which is given for Zephyr.
Diffstat (limited to 'web/CMakeLists.txt')
-rw-r--r--web/CMakeLists.txt9
1 files changed, 0 insertions, 9 deletions
diff --git a/web/CMakeLists.txt b/web/CMakeLists.txt
deleted file mode 100644
index 0cdb498..0000000
--- a/web/CMakeLists.txt
+++ /dev/null
@@ -1,9 +0,0 @@
-cmake_minimum_required(VERSION 3.10)
-
-include(hugo)
-
-hugo_site(
- "website"
- "${CMAKE_CURRENT_SOURCE_DIR}"
- "${CMAKE_CURRENT_BINARY_DIR}/public"
-)