summaryrefslogtreecommitdiff
path: root/web/content/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-04-05 15:28:04 +0200
committerxengineering <me@xengineering.eu>2025-04-05 15:28:04 +0200
commit00189e737517f4470336d819d52327a037509493 (patch)
tree8f7d2f3e616a89b807cf2986ecc6ee6876f99392 /web/content/meson.build
parent061a67ea6e4a7fb9658fd3efc1c670eae5ff3eb6 (diff)
downloadiot-contact-00189e737517f4470336d819d52327a037509493.tar
iot-contact-00189e737517f4470336d819d52327a037509493.tar.zst
iot-contact-00189e737517f4470336d819d52327a037509493.zip
web: Replace file copying by Meson installation
This makes the build system code way less hacky and more modular.
Diffstat (limited to 'web/content/meson.build')
-rw-r--r--web/content/meson.build29
1 files changed, 0 insertions, 29 deletions
diff --git a/web/content/meson.build b/web/content/meson.build
deleted file mode 100644
index 5046982..0000000
--- a/web/content/meson.build
+++ /dev/null
@@ -1,29 +0,0 @@
-configure_file(
- input: css,
- output: 'simple.css',
- copy: true,
-)
-
-schematic_web = custom_target('schematic_web',
- output: ['schematic.pdf'],
- command: [
- 'copy.py',
- schematic_pdf,
- meson.current_build_dir() / 'schematic.pdf'
- ],
- depends: [
- schematic,
- ],
-)
-
-bom_web = custom_target('bom_web',
- output: ['bill-of-materials.csv'],
- command: [
- 'copy.py',
- bom_csv,
- meson.current_build_dir() / 'bill-of-materials.csv'
- ],
- depends: [
- bom,
- ],
-)