summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-07 19:52:37 +0200
committerxengineering <me@xengineering.eu>2025-05-07 19:58:14 +0200
commit46b537fb86e029978d9a1f8aa5d07ec2949ea7a1 (patch)
tree71ef55ce4a9862d57bdc401c739363fb9f99894b /web/meson.build
parenta5aafcbd0398ae3893a83827cf66d4352eaee8f0 (diff)
downloadiot-contact-improve-buildsystem.tar
iot-contact-improve-buildsystem.tar.zst
iot-contact-improve-buildsystem.zip
WIP: Remove installation stepimprove-buildsystem
TODO: Check if the bootloader install target is still usable. Using the installation step to copy selected artifacts into on folder was anyway a hack. This commit shows that the complexity can be reduced by adding copy targets. The `build/artifacts` folder contains the selected artifacts, they are always up to date, the user does not have to call the install step separately and the target definitions do not require install-related keyword arguments.
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/web/meson.build b/web/meson.build
index f8c2024..19551a5 100644
--- a/web/meson.build
+++ b/web/meson.build
@@ -1,6 +1 @@
-website = fs.copyfile(
- meson.current_source_dir() / 'index.html',
- 'index.html',
- install: true,
- install_dir: '/',
-)
+index_html = fs.copyfile(meson.current_source_dir() / 'index.html')