summaryrefslogtreecommitdiff
path: root/web/meson.build
diff options
context:
space:
mode:
authorxengineering <me@xengineering.eu>2025-05-24 11:18:38 +0200
committerxengineering <me@xengineering.eu>2025-05-24 11:18:38 +0200
commitcaf416218623d6778b3d0c2fe12ee08135c2d126 (patch)
treeed255392f80eb2c692d585d86a78c1ac971db966 /web/meson.build
parentb1838d1c5b6bd27757d50d784543ea0ae16c1769 (diff)
downloadiot-contact-caf416218623d6778b3d0c2fe12ee08135c2d126.tar
iot-contact-caf416218623d6778b3d0c2fe12ee08135c2d126.tar.zst
iot-contact-caf416218623d6778b3d0c2fe12ee08135c2d126.zip
Remove installation step
Using the installation step to copy selected artifacts into one folder was anyway a hack. This commit shows that the complexity can be reduced by adding copy targets. The `build/artifacts` folder contains the selected artifacts, they are always up to date, the user does not have to call the install step separately and the target definitions do not require install-related keyword arguments.
Diffstat (limited to 'web/meson.build')
-rw-r--r--web/meson.build7
1 files changed, 1 insertions, 6 deletions
diff --git a/web/meson.build b/web/meson.build
index f8c2024..19551a5 100644
--- a/web/meson.build
+++ b/web/meson.build
@@ -1,6 +1 @@
-website = fs.copyfile(
- meson.current_source_dir() / 'index.html',
- 'index.html',
- install: true,
- install_dir: '/',
-)
+index_html = fs.copyfile(meson.current_source_dir() / 'index.html')