summaryrefslogtreecommitdiff
path: root/artifacts/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'artifacts/meson.build')
-rw-r--r--artifacts/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/artifacts/meson.build b/artifacts/meson.build
new file mode 100644
index 0000000..ac15661
--- /dev/null
+++ b/artifacts/meson.build
@@ -0,0 +1,23 @@
+artifacts = [
+ index_html,
+ css,
+ schematic,
+ bom,
+ simulation,
+ update_image,
+ factory_image,
+ kicad_pcb,
+]
+
+foreach artifact : artifacts
+ custom_target(
+ output: [fs.name(artifact.full_path())],
+ command: [
+ cp,
+ artifact.full_path(),
+ meson.current_build_dir(),
+ ],
+ depends: artifact,
+ build_by_default: true,
+ )
+endforeach